注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

dingchaoqun12 的博客

上海股票期货开户

 
 
 

日志

 
 
 
 

Ip Unnumbered使用实例 - Net130.com  

2013-02-03 11:31:29|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
Ip Unnumbered使用实例

www.net130.com     日期:2006-6-9    浏览次数: 5322
出处:思科 思索



图1.1 某公司的网络拓扑图
1.1 使用背景
假设有一家公司。总部在北京,在深圳、上海各有一个分公司。在武汉有一个办事处。它的网络情况参加图1.1。R是总部的路由器,它通过电话网(PSTN)与各个分公 司、办事处的路由器R1、R2、R3相连。 R、R1、R2、R3四台路由器都有一个串口(用于拨号),一个以太网口用于连接本地的网络。

以R、R1为例,R与R1连通,则R、R1的串口上必须配有IP地址,才能实现互通。对于路由器来说,不同的接口必须配置不同网段的IP地址。这样R、R1的以太网口和串口的IP地址必须在不同的网段。R2、R3也是如此。而一个最小的网段也必须有四个IP地址。因此,该公司为了实现总部与各个分公司、办事处的互通,就必须拿出16(四台路由器×四个IP地址)个IP地址来。如果该公司申请了一个C类地址(一共有255个IP地址),就只有239个IP地址可用与内部的主机。如果该公司有N个分公司、M个办事处,就需要拿出(N+M)×4个IP地址用于路由器的互通。此时剩下的可用IP地址就更少了。

但是仔细想一下,保留给路由器串口的IP地址实际上仅仅是用于实现路由器间的互通,除此再没有别的用途了。在这样一种背景下,借用IP地址(Ip unnumbered)的功能就产生了。

1.2 使用方法
所谓“借用IP地址”实际就是:一个接口上没有配置IP地址,但是还想使用该接口。就向其它有IP地址的接口借一个IP地址来。如果被借用接口有多个IP地址,只能借来主IP地址。如果被借用接口没有IP地址,则借用接口的IP地址为0.0.0.0。该功能通过Ip unnumbered命令来实现。

Ip unnumbered interface number
[no]Ip unnumbered

例如封装PPP的串口借用以太网口的IP地址:

Quidway(config-if-Serial0)#ip unnumbered ethernet 0

由于借用接口本身没有IP地址,无法加上路由,所以必须手工配置两条路由才能实现路由器的连通。请参见下面的实例。

2 使用实例

我们就以图1.1所示的某公司的网络情况为例子,讲解一下具体的配置方法。

先讲总部路由器R的配置方法。R的串口用于连接各个分公司、办事处的路由器。所以可借用以太网口的IP地址。

Current configuration:
!
hostname beijing
!
interface Ethernet0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0
ip unnumbered Ethernet0:借用以太网的IP地址
encapsulation ppp
!
ip route 172.16.20.1 255.255.255.0 172.16.20.1:配置到深圳路由器R1以太网网段的路由
ip route 172.16.20.1 255.255.255.255 serial0:配置到深圳路由器R1串口的接口路由

以深圳分公司的路由器R1为例,讲解一下它的配置:

Current configuration:
!
hostname shenzhen
!
interface Ethernet0
ip address 172.16.20.1 255.255.255.0
!
interface Serial0
ip unnumbered Ethernet0
encapsulation ppp
!
ip route 0.0.0.0 0.0.0.0 172.16.10.1: 配置到北京路由器R以太网网段的路由
ip route 172.16.10.1 255.255.255.255 serial0: 配置到北京路由器R串口的接口路由

为突出主题,上面的配置只包含了与借用IP地址相关的配置。这里需要提请注意的是:路由的配置。

在北京总部的路由器R上必须配置两条静态路由才能访问到深圳路由器R1的以太网上的主机。第一条静态路由是到R1的以太网段的网段路由:下一跳为R1的串口的IP地址(或是借用的IP地址)。

ip route 172.16.20.1 255.255.255.0 172.16.20.1

第二条静态路由是到R1串口的接口路由,下一跳是R的串口。

ip route 172.16.20.1 255.255.255.255 serial0

加上这两条路由后,R就能把访问R1以太网段的IP报文正确地转发给R1。

同样,在R1上也要配置两条静态路由才能正确地访问到R的以太网网段。第一条静态路由是到R的以太网段的网段路由:下一跳为R的串口的IP地址(或是借用的IP地址)。

ip route 0.0.0.0 0.0.0.0 172.16.10.1

第二条静态路由是到R串口的接口路由,下一跳是R1的串口。

ip route 172.16.10.1 255.255.255.255 serial0

R2、R3参照R1的配置即可.



引文来源  Ip Unnumbered使用实例 - Net130.com
  评论这张
 
阅读(369)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017