注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

dingchaoqun12 的博客

上海股票期货开户

 
 
 

日志

 
 
 
 

Platform SDK for VC6 - DOER - lipingke - 和讯博客  

2012-04-22 08:05:48|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
Platform SDK for VC6 [原创 2009-03-05 14:45:33] Platform SDK for VC6 - DOER - lipingke - 和讯博客 - dingchaoqun12 - dingchaoqun12 的博客 Platform SDK for VC6 - DOER - lipingke - 和讯博客 - dingchaoqun12 - dingchaoqun12 的博客 
我顶 字号:
我们在下载 SDK 时,微软网站上有这么一句话:

Development Tools. To build the C/C++ samples, you must have a C/C++ compiler. If you are using Microsoft Visual C/C++®, run it at least once before installing the SDK. This will ensure that the environment variables are correctly configured. To build the Visual Basic samples, you must have Microsoft Visual Basic®. This SDK does not support working with Microsoft Visual C/C++®, 6.0 as support for VC 6.0 has ended. The last SDK that will work with VC 6.0 is the February 2003 Edition, you can order a CD on the fulfillment site. Side by side installations are not supported.

  可见微软已经不再对 VC6 支持了,最新的 SDK 已经不能在 VC6 上使用。但是还是可以找到支持 VC6 的最后两个版本:

For Server2003 3790.0 RTM:   Size (bytes):   342,000,000   Last Updated:   February 2003

For XPSP2 2600.2180 RTM:     Size (bytes):   266,000,000   Last Updated:   August 2004

它们的下载地址是:

http://www.microsoft.com/msdownload/platformsdk/sdkupdate/downlevel.htm

以下是它们的单独链接:

For Server2003 3790.0 RTM:
http://www.microsoft.com/msdownload/platformsdk/sdkupdate/psdk-full.htm


For XPSP2 2600.2180 RTM:
http://www.microsoft.com/msdownload/platformsdk/sdkupdate/XPSP2FULLInstall.htm

  因为 VC6 是 98 年出来的,所有 win2k 及以上版本中新的功能都不能使用,主要是缺少头文件和库文件,有些 API 无法调用,Platform SDK 就是为解决这个问题的。

  根据开发环境选择不同版本的 SDK 来升级 VC6,就可以满足我们的编程要求。

  但是,我们还是要注意:为什么微软不支持 VC6 了呢?

  因为“取消对 Visual C++ 6.0 的支持的原因是为了支持新的 /GS 参数。XP SP2 和Windows Server 2003 SP1 都增加了很多安全特性,以致于新的 Windows SDK 中包含的编译器和库文件不再和 Visual C++ 6.0 兼容。”


/GS (Buffer Security Check), Visual C++ Compiler Options
Compiler Security Checks in Depth

  因此,如果要在新平台上进行开发,下载最新的编译器就可以了。VC2008 大得出奇,我是不想下了的,反正所有开发工作还是以 XP 为主,VC6 升级一下 SDK ,还是蛮好用的。




引文来源  Platform SDK for VC6 - DOER - lipingke - 和讯博客
  评论这张
 
阅读(591)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017